Downtime and degraded performance because of AWS issues

Incident Report for UXCam

Resolved

This incident has been resolved.
Posted Jun 10, 2022 - 07:12 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 10, 2022 - 07:11 UTC

Monitoring

Our system is now recovering and we are monitoring closely.
Posted Jun 10, 2022 - 06:06 UTC

Identified

We are observing downtime and degraded performance in verify-service, session-processing, and dashboard because our cloud-provider AWS is having issues.
Posted Jun 10, 2022 - 04:57 UTC
This incident affected: Processing (Session Verification API, Session Processing) and Application (Dashboard).